Examples: query, "exact match", wildcard*, wild?ard, wild*rd
Fuzzy search: cake~ (finds cakes, bake)
Term boost: "red velvet"^4, chocolate^2
Field grouping: tags:(+work -"fun-stuff")
Escape special characters +-&|!(){}[]^"~*?:\ - e.g. \+ \* \!
Range search: properties.timestamp:[1587729413488 TO *] (inclusive), properties.title:{A TO Z}(excluding A and Z)
Combinations: chocolate AND vanilla, chocolate OR vanilla, (chocolate OR vanilla) NOT "vanilla pudding"
Field search: properties.title:"The Title" AND text
Answered
COnX public maven repository

Hi,

ich bin dabei unsere COnX app von 1.4.0 auf 1.4.1 zu migrieren. Dabei ist es mir aufgefallen dass der maven repo https://nexus.campusonline.community/repository/campusonline-public-maven die "conx.platform.version" 1.4.(oder 1.4.2 oder 2.0.0) nicht resolven kann.
Gibt es eine maven repo mirror der nicht hinter VPN ist?

Hier ist der maven log von die felende artefacts:

Cannot resolve at.campusonline.conx.api:pub-i18n-api-rest-services:unknown
Cannot resolve at.campusonline.conx.api:pub-jaxrs-api:unknown
Cannot resolve io.quarkus:quarkus-oidc-client:unknown
Cannot resolve io.quarkus:quarkus-oidc:unknown
Cannot resolve io.quarkus:quarkus-config-yaml:unknown
Cannot resolve io.quarkus:quarkus-rest-client:unknown
Cannot resolve io.quarkus:quarkus-smallrye-health:unknown
Cannot resolve io.quarkus:quarkus-oidc-client-filter:unknown
Cannot resolve at.campusonline.conx.api:pub-auth-api:unknown
Cannot resolve io.quarkus:quarkus-test-security:unknown
Cannot resolve io.rest-assured:rest-assured:unknown
Cannot resolve io.quarkus:quarkus-hibernate-orm-panache:unknown
Cannot resolve at.campusonline.conx.api:pub-desktop-rest-services-quarkus-impl:unknown
Cannot resolve at.campusonline.conx.api:pub-jaxrs-api-logging-impl:unknown
Cannot resolve io.quarkus:quarkus-smallrye-openapi:unknown
Cannot resolve io.quarkus:quarkus-jdbc-h2:unknown
Cannot resolve at.campusonline.conx.api:pub-auth-api-impl-quarkus:unknown
Cannot resolve io.quarkus:quarkus-junit5:unknown
Cannot resolve io.quarkus:quarkus-resteasy-jsonb:unknown
Cannot resolve io.quarkus:quarkus-hibernate-validator:unknown
Cannot resolve io.quarkus:quarkus-cache:unknown
Cannot resolve io.quarkus:quarkus-jdbc-oracle:unknown
Cannot resolve io.quarkus:quarkus-resteasy-jaxb:unknown
Cannot resolve at.campusonline.conx.api:pub-auth-api-oidc-dad-hack-quarkus:unknown
Cannot resolve io.quarkus:quarkus-reactive-routes:unknown
Cannot resolve io.quarkus:quarkus-hibernate-orm:unknown
Cannot resolve io.quarkus:quarkus-undertow:unknown
Cannot resolve io.quarkus:quarkus-test-security-oidc:unknown
Cannot resolve at.campusonline.conx.api:pub-auth-api-rest-services:unknown
Cannot resolve io.quarkus:quarkus-container-image-jib:unknown
Cannot resolve at.campusonline.conx.api:pub-jaxrs-status-service:unknown
Cannot resolve io.quarkus:quarkus-resteasy:unknown
Cannot resolve org.mockito:mockito-inline:unknown
Cannot resolve at.campusonline.conx.api:pub-jaxrs-standard-error-mapper:unknown
Cannot resolve io.quarkus:quarkus-junit5-mockito:unknown
Cannot resolve at.campusonline.conx.api:pub-jaxrs-api-impl-quarkus:unknown
Cannot resolve io.quarkus:quarkus-liquibase:unknown
Cannot resolve org.projectlombok:lombok:unknown

In the example project you use the https://conexus.tugraz.at/nexus/repository/campusonline-public-maven but I'm using https://nexus.campusonline.community/repository/campusonline-public-maven

  
  
Posted 3 months ago
Edited 3 months ago
  
  

Hi, all relevant artefacts should be accessible on the community nexus. Can you post a specific artifact that is missing? This repo is a mirror of the internal and artifacts will be cached on demand, so if it has never been downloaded it might be missing in the index.

Lucas Reeh   3 months ago Report
  
  

I've updated the question with the missing artefacts

functionaldude   3 months ago Report
Votes Newest

Answers 2


Ah, i've just figured it out... despite im updating to COnX version 1.4.2, the conx.platform.version variable in the pom.xml must still be 1.4.0. If I set it to 1.4.0 everything works.

  
  

great that you figured it out :) else you can run help:effective-pom goal to see all substituted values in maven.

Lucas Reeh   3 months ago Report

From your log i can see that maven tries to download version: "unknown", please check your pom if you set the property correctly.

https://gitlab.campusonline.community/campusonline/conx-examples/-/blob/1.4.2/co-supersonic/pom.xml?ref_type=tags#L23

https://gitlab.campusonline.community/campusonline/conx-examples/-/blob/1.4.2/co-supersonic/pom.xml?ref_type=tags#L46

  
  
Posted 3 months ago
Lucas Reeh
108 × 4 Administrator
  
  

the pub-universe-bom version is set to ${conx.platform.version}

functionaldude   3 months ago Report
508 Views
2 Answers
3 months ago
3 months ago
Tags